Unable to fund or request loans

Incident Report for SoLo Status

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:33 UTC

Monitoring

We are starting to see a recovery across all of our services.
Posted Jun 12, 2025 - 20:49 UTC

Identified

Our third party services are experiencing a worldwide disruption. This is impacting our ability to request and fund loans.
Posted Jun 12, 2025 - 19:39 UTC
This incident affected: Wallet (Deposit, Instant Withdrawal, ACH Withdrawal), Payment (Adding an External Debit Card, SoLo Debit Card, SoLo Wallet), Marketplace (Loan Request, Loan Proposals), Member Funding (Funding - Cash, Funding - Credits, Funding - Debit Card, Funding - Credits + Debit Card), and Member Repayments.